1. Welcome to the Digiex Download Center, you are welcome to download anything you like here, no registration is required! We offer direct download links with no captchas or wait times.
    We do our best to ensure no content infringes copyrights, and provide a DMCA Takedown Request Form to request the removal of content from Digiex

Acer Aspire AS5633WLMi Laptop Vista / Windows 7 x64 Drivers

Discussion in 'Drivers' started by Nimrod, Dec 26, 2007.

  1. Nimrod

    Nimrod Exotic Vendor

    Joined:
    Jun 1, 2007
    Messages:
    1,989
    Likes Received:
    526
    Location:
    London, United Kingdom
    Acer Aspire AS5633WLMi Laptop
    Vista x64 Drivers



    After purchasing this laptop, I found the lack of 64-bit Vista Drivers annoying.

    I even contacted Acer and reminded them that by the Microsoft Logo Licensing Program they were required to have 64-bit drivers available as they sold a 64-bit laptop with the Vista Logo on it. I got hung up on when on the phone, and my emails got ignored.

    So here are the drivers I managed to pull together from many resources on the internet. In each folder, look for a setup.exe program and run it one by one. Install the Chipset drivers first.

    Any questions or comments just reply and ask :)

    The drivers should also work on Windows 7.

    Download Acer Aspire AS5633WLMi Laptop Vista / Windows 7 x64 Drivers
     
    InsaneNutter and robert like this.
  2. smudge16uk

    smudge16uk New Member

    Joined:
    Feb 11, 2015
    Messages:
    1
    Likes Received:
    1
    Location:
    United Kingdom
    Hi.

    I can't thank you enough for submitting these 64 bit Acer 5633 laptop drivers.

    In a constructive vein, may I relate how I got through the process?

    I found Windows 7 HP 64bit a doddle to install in of itself.

    However, casting around for drivers for my own rather elderly 'flaptop' <bit like me, I suppose> was a pain.

    I only found this post and one other location offering any useful help.

    1) I didn't seem to need the chipset driver. W7 told me the one it put in was newer so I stuck with that.

    2) Same with the modem. W7 seemed well on top of both it and the USB bluetooth adaptor I forgot I left plugged in round the back! ;-).

    3) Suffered a slight hitch with the ENE drivers, though, for the PCMCIA and SD slot. Firmware said it had run but it lied. However, when I hit on the idea of using the hardware wizard and directing the items to the driver file within the application I met with success.

    4) Sound, wireless & ethernet were no problem and are up and running..

    5) I got a newish driver from NVidia for the graphics (huge file!) and found this worked a treat. ;-)

    6) Launch Manager worked fine.

    So, there we are. Software's all in up and running and 'smudge16uk' is one happy bunny as his pension will not have to get a replacement machine (or load Linux, the more likely choice!) yet awhile.

    Very many thanks for your work on these drivers.

    smudge16uk.
     
    InsaneNutter likes this.
  3. InsaneNutter

    InsaneNutter Resident Nutter Staff Member

    Joined:
    Jun 1, 2007
    Messages:
    11,112
    Likes Received:
    3,307
    Location:
    Yorkshire, England
    Great to see you found one of Digiex's earliest posts useful over 7 years after it was posted!

    I imagine the Aspire AS5633WLMi is still quite a usable laptop even today.
     

Share This Page