Fix for the AT&T Microcell power drain issue on a Nokia Lumia 900

Discussion in 'Mobile Devices' started by Nimrod, May 17, 2012.

  1. Nimrod

    Nimrod Exotic Vendor

    Joined:
    Jun 1, 2007
    Messages:
    1,989
    Likes Received:
    526
    Location:
    London, United Kingdom
    Many users in the US are experiencing major power drains on the new Nokia Lumia 900 when connected to an AT&T Microcell. Power drain is around 400mA instead of the usual 100-150mA causing a battery to go flat in only 9 hours.

    This is caused by AT&T's microcell being incorrectly configured and forcing the best possible connection even when the phone is idle (ie the phone keeps a constant high speed connection causing the radio in the phone to use tons of power). Sadly AT&T isn't capable of fixing this problem (and doesn't seem to care) despite it causing problems for tons of phones except for the iPhone where Apple have hardcoded a fix into their Firmware because they realised AT&T is incapable of hiring engineers.

    However, there is a permeant fix which doesn't involve turning off Cellular data and using Wifi (Which while it does resolve the issue, it stops push notifications or other data connections from working when the phone is asleep).

    You need to set the phone to only use 3G as its maximum data speed. This does mean you will need to un-do this outside if you enter a 4G LTE area and want full speed, but for day to day usage of emails this is a suitable fix.

    To unlock the menu to set 3G as maximum speed:

    Go to dialer and enter ##3282#, it opens the Data Field Test utility which includes a lot of stuff which you can mostly ignore. What you need to do is tap the "three dots" at the bottom of your screen and tap "settings"
    Change the Network type to Automatic.
    Tap the Back button once to go back to the Field Test menu.
    The next step is critical: tap on the last option on the screen; Toggle ENS (REBOOT). When it opens tap Start. A few seconds later tap Stop. After a slight pause your phone will reboot (soft reset). If you simply back out of the Field Test menu, your settings will not stick.


    Once complete, go to Settings>Cellular on your phone and you will have an option to select 3G as your highest connection speed.

    You should now find the battery usage is under control! Sadly it does mean your speed is limited to only 3G unless you undo the setting but if you are using Microcell its already likely your in a bad coverage area so this shouldn't matter too much.
     
    jessenic likes this.

Share This Page