Windows 8.1 Leaked RTM - Who's installed?

Discussion in 'Computer and Technology Discussion' started by Nimrod, Sep 1, 2013.

  1. Nimrod

    Nimrod Exotic Vendor

    Joined:
    Jun 1, 2007
    Messages:
    1,991
    Likes Received:
    530
    Location:
    London, United Kingdom
    So members of Digiex, have any of you jumped the October release date and already installed and activated (legally) the Windows 8.1 RTM leaks?

    I'm tempted, but haven't put the time in yet. If the process is going smoothly for others I may have to just get it done and dusted as I'm loving the 8.1 Preview at the moment.

    Also a side question - Can you update from the 8.1 Preview to the RTM builds?
     
  2. InsaneNutter

    InsaneNutter Resident Nutter Staff Member

    Joined:
    Jun 1, 2007
    Messages:
    11,895
    Likes Received:
    3,607
    Location:
    Yorkshire, England
    Something to keep in mind is the leaked English iso is EN-US, chances are your current install is EN-GB. As with the preview I don't believe you can upgrade an EN-GB install with an EN-US iso, without doing a total re install.

    You could do a clean install with the EN-US iso and set the date / time / region to British, then install the EN-GB language pack once the install has completed.

    As for upgrading to the RTM from the 8.1 preview Microsoft say its possible, but only your Metro app are kept (likely because with 8.1 they sync to the cloud and between multiple PC's) however all your normal apps and settings will be erased. Personally i would not really call that an upgrade.

    I'm happy with the 8.1 preview for now, ill probably end up just waiting.
     
  3. Neoteam1

    Neoteam1 Addict

    Joined:
    Apr 10, 2011
    Messages:
    711
    Likes Received:
    71
    Location:
    United Kingdom
    Iv installed this from windows 8.1 preview and before that I had windows 8. It upgrades from the latest OS even 7 and it works with ENG-US and UK all you need to do is select it from the language section when installing. The only crap thing is that it don't have. NET 2.0 or 3.0. So half the programs wont work.
     

Share This Page