How to fix youtube on Virginmedia by blocking cache proxy

Discussion in 'Networking Guides' started by supercity, Jun 28, 2013.

  1. supercity

    supercity Resident

    Joined:
    Sep 3, 2011
    Messages:
    113
    Likes Received:
    15
    Location:
    England
    I mean to cause no dis-respect to virginmedia... They are good in 95% of ways (Like Free usenet server) but youtube.... not great [​IMG]
    Virginmedia use a cache proxy for youtube which simply doesnt work. This guide for Windows & Mac will block virgn media's proxy and force all streaming to be done via youtube directly. It requires a few lines to be entered into a command prompt or terminal and can easily be un-done if required.

    For Windows, Start > Type "cmd" in the search > Right click cmd.exe and run as administrator.
    Copy and paste the following:

    Code:
    netsh advfirewall firewall add rule name="STOPCACHINGYOUTUBE" dir=in action=block remoteip=173.194.55.0/24,206.111.0.0/16,62.252.0.0/16 enable=yes

    For Mac, Open a terminal and copy/paste the following:

    Code:
    sudo ipfw add reject src-ip 173.194.55.0/24 in
    sudo ipfw add reject src-ip 206.111.0.0/16 in
    sudo ipfw add reject src-ip 62.252.0.0/16 in
    To remove on windows: netsh advfirewall firewall delete rule name="STOPCACHINGYOUTUBE"
    To remove on mac: sudo ipfw delete X

    Any Replies / Feedback / Other solutions would be much appreciated.

    I also posted this here: http://community.virginmedia.com/t5...ix-youtube-and-make-it-watchable/td-p/1885698
     
    xzKinGzxBuRnzx and InsaneNutter like this.
  2. InsaneNutter

    InsaneNutter Resident Nutter Staff Member

    Joined:
    Jun 1, 2007
    Messages:
    11,217
    Likes Received:
    3,336
    Location:
    Yorkshire, England
    Could be a nice little tip you have there, i shall test it out. I generally have no problems to be fair. My only issue on Virgin with YouTube is when switching to 1080p video, a lot of the time the video will either never load, or do so extremely slowly.
     
  3. supercity

    supercity Resident

    Joined:
    Sep 3, 2011
    Messages:
    113
    Likes Received:
    15
    Location:
    England
    For me, 240p, 360p, 480p and 720p all took 30+seconds to load.... whereas 1080p had no issues.

    Without the cache ip blocking, using https:// and then adding some /?radom_query=strings to the end of the URL helped :P
     

Share This Page